Re: [VOTE] JanusGraph 0.6.0 release

Clement de Groc

Hey Boxuan,

Good catch !

To the best of my knowledge, this type of error usually means there is a mix of scala 2.11 and scala 2.12 libraries.

TinkerPop 3.5 switched to Spark 3 and Scala 2.12 (

But I see (at least one) reference to Scala 2.11 libraries in janusgraph-hadoop (

I would try chasing down libraries pulling Scala 2.11 and upgrading them.
I can look into that on Monday if noone has before.


Le sam. 14 août 2021 à 06:36, Boxuan Li <liboxuan@...> a écrit :
I downloaded, tried a simple traversal using SparkGraphComputer on my laptop but failed:

:plugin use tinkerpop.hadoop
:plugin use tinkerpop.spark
graph ='conf/hadoop-graph/')
g = graph.traversal().withComputer(SparkGraphComputer)
with error `java.lang.NoSuchMethodError: scala.Predef$.refArrayOps([Ljava/lang/Object;)Lscala/collection/mutable/ArrayOps;`

I don't have scala or Spark installed locally. The same traversal worked well on the 0.5.3 version. I personally never ran any workload on Spark before, so I am not sure if this is expected, or due to a library conflict in Janusgraph distribution. If anyone familiar with Spark can shed some light or test by themselves, it would be very helpful. Otherwise, I am afraid 0.6.0 might not work well with Spark.


Join to automatically receive all group messages.