[WARNING] 0.1.0 to 0.1.1 upgrade


Alexander Patrikalakis <amcpatr...@...>
 

It seems like 0.2.0 is on the horizon for June/early July. If the next TinkerPop release slips, we may consider a 0.1.2 release to fix the JG 0.1.0 compatibility issue and include the following adjustment the DynamoDB backend would like to have:
https://github.com/JanusGraph/janusgraph/commit/5d9ebb46c0e11c57f9336e9f38057e6e3b2e49a5

Alex


On Thursday, May 18, 2017 at 12:19:05 PM UTC-10, Ted Wilmes wrote:
Hello,
A step was missed during the release prep and the 0.1.1 release was not marked as compatible with JanusGraph 0.1.0. Consequently, if you point 0.1.1 at a previously loaded 0.1.0 backend (not Titan), JanusGraph will not start and you'll get: 

"StorageBackend version is incompatible with current JanusGraph version: storage [0.1.0] vs. runtime [0.1.1]"

The backend format is not really incompatible and an issue has been entered to address this [1].

The 0.1.1 release mainly fixes a serious Titan compatibility issue [2] and if you are upgrading from Titan, you will not be affected by this incompatibility error and can upgrade because Janus is correctly marked as compatible with Titan 1.0 and Titan 1.1-SNAPSHOT.

If you are running 0.1.0 right now from a brand new JanusGraph load (not an upgrade from Titan), hold off on upgrading until this issues is taken care of. If you planned on rebuilding your data from scratch when upgrading to 0.1.1, you can go ahead and upgrade as this only affects a previously loaded system.

Thanks,
Ted


Ted Wilmes <twi...@...>
 

Hello,
A step was missed during the release prep and the 0.1.1 release was not marked as compatible with JanusGraph 0.1.0. Consequently, if you point 0.1.1 at a previously loaded 0.1.0 backend (not Titan), JanusGraph will not start and you'll get: 

"StorageBackend version is incompatible with current JanusGraph version: storage [0.1.0] vs. runtime [0.1.1]"

The backend format is not really incompatible and an issue has been entered to address this [1].

The 0.1.1 release mainly fixes a serious Titan compatibility issue [2] and if you are upgrading from Titan, you will not be affected by this incompatibility error and can upgrade because Janus is correctly marked as compatible with Titan 1.0 and Titan 1.1-SNAPSHOT.

If you are running 0.1.0 right now from a brand new JanusGraph load (not an upgrade from Titan), hold off on upgrading until this issues is taken care of. If you planned on rebuilding your data from scratch when upgrading to 0.1.1, you can go ahead and upgrade as this only affects a previously loaded system.

Thanks,
Ted