Re: Janus not able to connect to cassandra


Bharat Dighe <bdi...@...>
 

Found the issue. It was due to inclusion of netty-transport-native-epoll via another application dependency. It seems cassandra core driver 3.7.1 does not like if this library is present in the classpath.


Thanks
Bharat


On Friday, September 27, 2019 at 12:53:23 AM UTC-7, Florian Hockmann wrote:
Not sure if that can cause your problem but you need to configure storage.cql.keyspace instead of storage.cassandra.keyspace if you're using CQL and the same applies to the consistency levels.

Am Donnerstag, 26. September 2019 20:35:44 UTC+2 schrieb Bharat Dighe:
Didnt help.

Could this be a driver 3.7.1 compatibility issue with cassandra 3.11.3?

Thanks
Bharat

On Wednesday, September 25, 2019 at 7:28:57 PM UTC-7, akhilesh singh wrote:
Can you disable thrift on Cassandra and then try

On Thu 26 Sep, 2019, 4:28 AM Bharat Dighe, <b...@...> wrote:
I am using cql driver.

I am getting below  while opening connection. The C* is running on the localhost and listening on port 9042.
Cassandra version is 3.11.3

Connection Parameters:
storage.backend=cql
storage.cassandra.read-consistency-level=LOCAL_QUORUM
storage.cassandra.write-consistency-level=LOCAL_QUORUM
storage.read-only=true
storage.hostname=localhost
storage.cassandra.keyspace=my_ks
query.fast-property=true
query.force-index=true


>>netstat -an|grep 9042
tcp        0      0 0.0.0.0:9042                0.0.0.0:*                   LISTEN

It works fine when I use thrift driver.

What I am missing? Following is the exception

java.lang.IllegalArgumentException: Could not instantiate implementation: org.janusgraph.diskstorage.cql.CQLStoreManager
        at org.janusgraph.util.system.ConfigurationUtil.instantiate(ConfigurationUtil.java:64) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.diskstorage.Backend.getImplementationClass(Backend.java:440) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.diskstorage.Backend.getStorageManager(Backend.java:411) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.graphdb.configuration.builder.GraphDatabaseConfigurationBuilder.build(GraphDatabaseConfigurationBuilder.java:50) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.core.JanusGraphFactory.open(JanusGraphFactory.java:161) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.core.JanusGraphFactory.open(JanusGraphFactory.java:132) ~[janusgraph-core-0.4.0.jar:?]
        at org.janusgraph.core.JanusGraphFactory.open(JanusGraphFactory.java:112) ~[janusgraph-core-0.4.0.jar:?]
Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.GeneratedConstructorAccessor25.newInstance(Unknown Source) ~[?:?]
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) ~[?:1.8.0_222]
        at java.lang.reflect.Constructor.newInstance(Constructor.java:423) ~[?:1.8.0_222]
        at org.janusgraph.util.system.ConfigurationUtil.instantiate(ConfigurationUtil.java:58) ~[janusgraph-core-0.4.0.jar:?]
        ... 11 more
Caused by: com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: localhost/127.0.0.1:9042 (com.datastax.driver.core.exceptions.TransportException: [localhost/127.0.0.1:9042] Connection has been closed))
        at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:268) ~[cassandra-driver-core-3.7.1.jar:?]
        at com.datastax.driver.core.ControlConnection.connect(ControlConnection.java:107) ~[cassandra-driver-core-3.7.1.jar:?]
        at com.datastax.driver.core.Cluster$Manager.negotiateProtocolVersionAndConnect(Cluster.java:1652) ~[cassandra-driver-core-3.7.1.jar:?]
        at com.datastax.driver.core.Cluster$Manager.init(Cluster.java:1571) ~[cassandra-driver-core-3.7.1.jar:?]
        at com.datastax.driver.core.Cluster.init(Cluster.java:208) ~[cassandra-driver-core-3.7.1.jar:?]




--
You received this message because you are subscribed to the Google Groups "JanusGraph users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janu...@....
To view this discussion on the web visit https://groups.google.com/d/msgid/janusgraph-users/ab171f64-d3c8-4f16-a630-81de43891894%40googlegroups.com.

Join janusgraph-users@lists.lfaidata.foundation to automatically receive all group messages.