Re: Upgraded Janus Version to 0.4 and tinkerpop gremlin-server/console version to 3.4.1


Oleksandr Porunov <alexand...@...>
 

First of all version `0.4.0` doesn't support ES version 7. Version 0.5.0 supports ES 7 but it isn't released yet. You may build your own jars from source code to support ES version 7.
Also, I see that you are upgrading directly from "0.2.0" to "0.4.0". I personally didn't test it and would suggest to upgrade to version "0.3.0" and then "0.4.0".
See this upgrade instructions for 0.3.0: https://docs.janusgraph.org/changelog#upgrade-instructions_1
See this upgrade instructions for 0.4.0: https://docs.janusgraph.org/changelog#upgrade-instructions

On Friday, October 18, 2019 at 5:19:55 PM UTC+3, Baskar Vangili wrote:
I have upgraded janus version to 0.4.0 and tinker pop version to 3.4.1. 
Index Backend ES version: 7.3.2
Cassandra Version: 3.3.0

After the upgrade, I am getting this error. Any idea what's happening here? 

"error":"com.google.common.util.concurrent.UncheckedExecutionException: org.janusgraph.core.JanusGraphException: StorageBackend version is incompatible with current JanusGraph version: storage [0.4.0] vs. runtime [0.2.0]\n\tat com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2203)\n\tat com.google.common.cache.LocalCache.get(LocalCache.java:3937)\n\tat com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:3941)\n\tat com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:4824)



Join janusgraph-users@lists.lfaidata.foundation to automatically receive all group messages.