Re: JanusGraph support for Cassandra 3.x


Ted Wilmes <twi...@...>
 

Interesting, if you have a record of what your issues were, could you create a ticket? I haven't seen issues with Cassandra 3.10 
and the Astyanax adapter but maybe your setup or usage patterns were different. I'm assuming you enabled Thrift on your Cassandra cluster?

Thanks,
Ted


On Thursday, July 13, 2017 at 7:14:37 PM UTC-5, Vladyslav Kosulin wrote:
Astyanax with Cassandra 3?
I tried in other project, this combo did not work.

On Friday, July 7, 2017 at 3:09:23 PM UTC-4, Ted Wilmes wrote:
Hi Robert,
I've used the thrift and astyanax adapters and as of late, I've been dipping my toes into the new CQL adapter. So far that has worked well too against Apache Cassandra and Scylla 1.6.

--Ted

On Fri, Jul 7, 2017 at 1:55 PM, Robert Dale <r...@...> wrote:
Ted, what driver do you use?

Robert Dale

On Fri, Jul 7, 2017 at 2:28 PM, Ted Wilmes <t...@...> wrote:
Hi Vijaya,
I haven't had any issues running Janus in OLTP mode against Cassandra 3. Issue 172 is a problem if you want to run analytic queries using the TinkerPop SparkGraphComputer against your Janus data.

--Ted

On Friday, July 7, 2017 at 9:55:43 AM UTC-5, vijaya bhaskar Peddinti wrote:
Dear All,

Can we uses Janusgraph with Cassandra 3.x (as per docs it is mentioned only 2.1.z)? if not supported, Any new release planned with support for cassandra 3.x and when can it be expected?


I have gone through Issues#172 and 267 where this is extensively discussed but these are in Open state. 


thanks and regards,
Vijaya Bhaskar Peddinti

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


Join janusgraph-users@lists.lfaidata.foundation to automatically receive all group messages.