Re: Problem downloading JanusGraph as a maven artifact.


Jason Plurad <plu...@...>
 

That dependency isn't found in Maven central, jbcrypt-0.4 is found in the jitpack.io repository. You'll need to add a remote repository for it.

If you're using the Gremlin Console, you can use the ~/.groovy/grapeConfig.xml found here http://tinkerpop.apache.org/docs/3.2.4/reference/#gremlin-applications

<ivysettings> <settings defaultResolver="downloadGrapes"/> <resolvers> <chain name="downloadGrapes"> <filesystem name="cachedGrapes"> <ivy pattern="${user.home}/.groovy/grapes/[organisation]/[module]/ivy-[revision].xml"/> <artifact pattern="${user.home}/.groovy/grapes/[organisation]/[module]/[type]s/[artifact]-[revision].[ext]"/> </filesystem> <ibiblio name="central" root="http://central.maven.org/maven2/" m2compatible="true"/> <ibiblio name="jitpack" root="https://jitpack.io" m2compatible="true"/> <ibiblio name="java.net2" root="http://download.java.net/maven/2/" m2compatible="true"/> </chain> </resolvers> </ivysettings>

If you're using Maven, you could use the dependency:get command:

mvn dependency:get -DremoteRepositories="https://jitpack.io" -Dartifact="com.github.jeremyh:jBCrypt:jbcrypt-0.4"

I'm not an SBT user, but it looks like this is the way to do it:

resolvers += "jitpack" at "https://jitpack.io"
libraryDependencies += "com.github.jeremyh" % "jBCrypt" % "jbcrypt-0.4"    

-- Jason


On Monday, August 7, 2017 at 8:30:40 AM UTC-4, Manoj Waikar wrote:
Hi,

I am trying to use JanusGraph 0.1.1 in a Scala project, and the SBT dependency on -
"org.janusgraph" % "janusgraph-core" % "0.1.1"

fails to download with these errors -
Error:Error while importing SBT project:<br/>...<br/><pre>[warn] :: com.github.jeremyh#jBCrypt;jbcrypt-0.4: not found
[warn] :: com.google.guava#guava;18.0: configuration not found in com.google.guava#guava;18.0: 'master(compile)'. Missing configuration: 'compile'. It was required from org.janusgraph#janusgraph-core;0.1.1 compile
[warn] ::::::::::::::::::::::::::::::::::::::::::::::
[warn]
[warn] Note: Unresolved dependencies path:
[warn] com.github.jeremyh:jBCrypt:jbcrypt-0.4
[warn]  +- org.apache.tinkerpop:gremlin-groovy:3.2.3
[warn]  +- org.janusgraph:janusgraph-core:0.1.1 (F:\intercax\source-code\hello-worlds\scala-repos\janusscala\build.sbt#L11)
[warn] com.google.guava:guava:18.0
[warn]  +- org.janusgraph:janusgraph-core:0.1.1 (F:\intercax\source-code\hello-worlds\scala-repos\janusscala\build.sbt#L11)
[trace] Stack trace suppressed: run 'last *:ssExtractDependencies' for the full output.
[trace] Stack trace suppressed: run 'last *:update' for the full output.
[error] (*:ssExtractDependencies) sbt.ResolveException: unresolved dependency: com.github.jeremyh#jBCrypt;jbcrypt-0.4: not found
[error] unresolved dependency: com.google.guava#guava;18.0: configuration not found in com.google.guava#guava;18.0: 'master(compile)'. Missing configuration: 'compile'. It was required from org.janusgraph#janusgraph-core;0.1.1 compile
[error] (*:update) sbt.ResolveException: unresolved dependency: com.github.jeremyh#jBCrypt;jbcrypt-0.4: not found
[error] unresolved dependency: com.google.guava#guava;18.0: configuration not found in com.google.guava#guava;18.0: 'master(compile)'. Missing configuration: 'compile'. It was required from org.janusgraph#janusgraph-core;0.1.1 compile
[error] Total time: 6 s, completed 7 Aug, 2017 5:55:37 PM

Any idea on how should I proceed ahead with this? Thanks in advance.

Join janusgraph-users@lists.lfaidata.foundation to automatically receive all group messages.