Help needed! Configure janusgraph-1.0.0-docker (either rebuild from base or docker compose with env variable setting) to use ConfigurationManagementGraph, and then initialize it with own graph & schema

Yingjie Li


Sorry if this post is kind of a continuation of my last  post. As I have not received any suggestion, so i would like to start a new thread to surface up the problem. 

I would like to know the exactly code for me to be able to configure janusgraph-1.0.0-docker (either rebuild a new image from this base) or docker-compose it with env variable settings.  So that I can use ConfigurationManagementGraph and graph traversal for query.  I will need it to be initialized with my own schema groovy (where I define the graph name,  set up other configurations and created composite/mixed index into Cassandra/ElasticSearch( I used OpenSearch instead and it kind of worked).  A sample schema (init_graph_sample1.groovy) is attached, This is similar to the schema I have been using in Januagraph prepcakged versions.

From the previous response I got, it seems all these should have been supported already, but unfortunately it does not work for me with my various tries. I feel I am on the right track, but not exactly there yet. 

I attached a Docker file  (please ignore the jar removal part for now)  that I would like your help to adding the necessary code to use ConfigurationManagementGraph. Only after I get the configuration right, I can initize it with my own schema as attached, 


If you have a docker compose that shows the env settings for the above, I am glad to try that as well. I have been trying getting these settings in a env file of docker compose, but it did not work except for the last line. 



I have been using jansguraph prepackage versions, where I know exactly what yaml file to replace/change  to enable the above. But it becomes kind of mystery of how to do it in the unprepackage version.

I also tried having a local install of janusgraph-1.0.0-rc2, and invoke server by providing a configuration file which i think should be used: 

./bin/ start conf/gremlin-server/gremlin-server-configuration-cql-es.yaml

And after starting, I can create my own graph graph1 using ConfiguredGraphFactory, and can create mixed index, and I can see the graph1 is created in the backend cassandra and my indexes (not exactly the same name)  are created in the backend OpenSearch (ElasticSearch), pictures are attached, but I am not able to use graph1_traversal to query the graph. 


My request is kind of urgent as Janusgraph has been the core of our project that has been going on for two/three years, and we really need your help to bring it to the next level  for potential production. We have been used prepackaged version starting from 0.5.3, and recently we need to replace the all in one (janusgraph1.0.0-rc1-ful) with the lastest (janusgraph1.0.0-rc2) and use Cassandra and OpenSearch.  

Due to a tight deadline, would appreciate somebody can help me as soon as possible.  

Join { to automatically receive all group messages.