Droping a graph delete all other graph indexes on Solr


After some investigation from my colleagues, the problem may come from the file SolrIndex.java on method clearStorage line 971


Note: I tried to disable the graph2 index and remove it in Solr but problem persists.


Hello everyone,

I don't know if it's an issue or I have done something wrong but droping a graph delete all other indexes in solr.

How I create my graphs:

def map = new HashMap<String, Object>();
map.put(""gremlin.graph"", ""org.janusgraph.core.ConfiguredGraphFactory"");
map.put(""graph.graphname"", ""{name}"");
map.put(""schema.default"", ""none"");
map.put(""storage.backend"", ""inmemory"");
map.put(""storage.buffer-size"", 10000);
map.put(""storage.batch-loading"", true);
map.put(""storage.parallel-backend-ops"", true);
map.put(""storage.transactions"", false);
map.put(""ids.block-size"", 100000);
map.put(""index.solr.backend"", ""solr"");
map.put(""index.solr.max-result-set-size"", 100000);
map.put(""index.solr.solr.mode"", ""cloud"");
map.put(""index.solr.solr.zookeeper-url"", ""{_solrBackendService.GetZookeeperHostUrl()}"");
map.put(""index.solr.solr.http-urls"", ""{_solrBackendService.GetBackendUrl()}"");
map.put(""index.solr.solr.configset"", ""janusgraph-configset"");
map.put(""index.solr.solr.wait-searcher"", true);
ConfiguredGraphFactory.createConfiguration(new MapConfiguration(map));

In solr admin web page I check that my graph1 index has data.
In Gremlin console I check that my graph2 has only its index with:
When I run ConfiguredGraphFactory.drop("graph2"), I don't have data anymore in my graph1 index in solr admin page.

Thank you for your help.