Failure on mvn clean install


hadoopmarc@...
 
Edited

Thanks for reporting. Somehow, the tests for janusgraph-examples do not pass anymore when run in a stand-alone fashion (these tests are also run in the CI from the main pom.xml in https://github.com/JanusGraph/janusgraph/blob/master/pom.xml , where obviously they do pass). I reported an issue for this. https://github.com/JanusGraph/janusgraph/issues/2911

If you just want to run the examples you can build the jar with:
mvn clean install -DskipTests
Best wishes,     Marc


benanavd@...
 

Just unpacked janusgraph-full-0.6.0.zip and got the server started with ./bin/janusgraph-server.sh console. It started up fine. Then I cd to the examples directory and to a mvn clean install. I get the following errors
[ERROR] Failures: 
[ERROR]   GraphAppTest.openGraphConfigNotFound:70 Unexpected exception type thrown ==> expected: <java.io.FileNotFoundException> but was: <org.apache.commons.configuration2.ex.ConfigurationException>
[ERROR]   GraphAppTest.openGraphNullConfig:65 Unexpected exception type thrown ==> expected: <java.lang.NullPointerException> but was: <java.lang.RuntimeException>
[INFO] 
[ERROR] Tests run: 7, Failures: 2, Errors: 0, Skipped: 0
[INFO] 
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary for JanusGraph-Examples: Examples for JanusGraph 0.6.0:
[INFO] 
[INFO] JanusGraph-Examples: Examples for JanusGraph ....... SUCCESS [  2.603 s]
[INFO] Example-Common: Common Graph Code for Examples ..... FAILURE [  6.387 s]
[INFO] Example-BerkeleyJE: BerkeleyJE Storage, Lucene Index SKIPPED
[INFO] Example-Cql: Cassandra CQL Storage, Elasticsearch Index SKIPPED
[INFO] Example-HBase: HBase Storage, Solr Index ........... SKIPPED
[INFO] Example-RemoteGraph: Example with RemoteGraph ...... SKIPPED
[INFO] Example-TinkerGraph: Example with TinkerGraph ...... SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] -----------------------------------------------
 
Any ideas how to fix that?
 
I've been trying to setup JanusGraph all day and can't seem to figure it out!