A few observations about JanusGraph scripts / config files.


Manoj Waikar <mmwa...@...>
 

Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?


Robert Dale <rob...@...>
 

I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mmwa...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-users+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


pradeep...@...
 

Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep


On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jason Plurad <plu...@...>
 

What OS/environment are your running this on?

datazone. cool.


On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


pradeep...@...
 

RHEL 7.2 version...


On Thursday, October 12, 2017 at 7:34:53 AM UTC+5:30, Jason Plurad wrote:
What OS/environment are your running this on?

datazone. cool.

On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jason Plurad <plu...@...>
 

Can you try this, uncomment following line in conf/cassandra-env.sh :

    JVM_OPTS="$JVM_OPTS -Djava.rmi.server.hostname=127.0.0.1"


Reference https://github.com/JanusGraph/janusgraph/issues/561


On Wednesday, October 11, 2017 at 10:09:13 PM UTC-4, pradeep.datazone wrote:
RHEL 7.2 version...

On Thursday, October 12, 2017 at 7:34:53 AM UTC+5:30, Jason Plurad wrote:
What OS/environment are your running this on?

datazone. cool.

On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Jason Plurad <plu...@...>
 

Is your RHEL machine configured for IPv6? Is the hostname resolvable?
This might be related https://issues.apache.org/jira/browse/CASSANDRA-2380


On Wednesday, October 11, 2017 at 10:28:58 PM UTC-4, Jason Plurad wrote:
Can you try this, uncomment following line in conf/cassandra-env.sh :

    JVM_OPTS="$JVM_OPTS -Djava.rmi.server.hostname=127.0.0.1"


Reference https://github.com/JanusGraph/janusgraph/issues/561

On Wednesday, October 11, 2017 at 10:09:13 PM UTC-4, pradeep.datazone wrote:
RHEL 7.2 version...

On Thursday, October 12, 2017 at 7:34:53 AM UTC+5:30, Jason Plurad wrote:
What OS/environment are your running this on?

datazone. cool.

On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


Robert Dale <rob...@...>
 

Start with verbose:   ./bin/janusgraph.sh -v


Robert Dale

On Wed, Oct 11, 2017 at 10:35 PM, Jason Plurad <plu...@...> wrote:
Is your RHEL machine configured for IPv6? Is the hostname resolvable?
This might be related https://issues.apache.org/jira/browse/CASSANDRA-2380


On Wednesday, October 11, 2017 at 10:28:58 PM UTC-4, Jason Plurad wrote:
Can you try this, uncomment following line in conf/cassandra-env.sh :

    JVM_OPTS="$JVM_OPTS -Djava.rmi.server.hostname=127.0.0.1"


Reference https://github.com/JanusGraph/janusgraph/issues/561

On Wednesday, October 11, 2017 at 10:09:13 PM UTC-4, pradeep.datazone wrote:
RHEL 7.2 version...

On Thursday, October 12, 2017 at 7:34:53 AM UTC+5:30, Jason Plurad wrote:
What OS/environment are your running this on?

datazone. cool.

On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "JanusGraph users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-users+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/janusgraph-users/118fcbc6-f5fd-45f7-9b90-11f20b7143cc%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.


pradeep...@...
 

Thanks it worked ....


On Thursday, October 12, 2017 at 8:05:38 AM UTC+5:30, Jason Plurad wrote:
Is your RHEL machine configured for IPv6? Is the hostname resolvable?
This might be related https://issues.apache.org/jira/browse/CASSANDRA-2380

On Wednesday, October 11, 2017 at 10:28:58 PM UTC-4, Jason Plurad wrote:
Can you try this, uncomment following line in conf/cassandra-env.sh :

    JVM_OPTS="$JVM_OPTS -Djava.rmi.server.hostname=127.0.0.1"


Reference https://github.com/JanusGraph/janusgraph/issues/561

On Wednesday, October 11, 2017 at 10:09:13 PM UTC-4, pradeep.datazone wrote:
RHEL 7.2 version...

On Thursday, October 12, 2017 at 7:34:53 AM UTC+5:30, Jason Plurad wrote:
What OS/environment are your running this on?

datazone. cool.

On Wednesday, October 11, 2017 at 10:01:11 PM UTC-4, pradeep.datazone wrote:
Hi,

I've been also getting the same timeout error and didn't get any success so far.
Please help me to understand where is gap, nothing is coming in cassandra.log file also.

./janusgraph.sh start
Forking Cassandra...
Running `nodetool statusthrift`............... timeout exceeded (60 seconds)
See /root/janusgraph-0.1.1-hadoop2/bin/../log/cassandra.log for Cassandra log output.

_Pradeep

On Wednesday, August 16, 2017 at 5:53:07 PM UTC+5:30, Robert Dale wrote:
I am unable to find '8183' ever having existed in the code base.  

Robert Dale

On Wed, Aug 16, 2017 at 2:26 AM, Manoj Waikar <mm...@...> wrote:
Hi,

On Windows, using a terminal client like Babun one can run the bin/janusgraph.sh script. I tried running it but it doesn't work for me and this is the output -

Forking Cassandra...
Running `nodetool statusthrift`............ timeout exceeded (60 seconds)

Also, in section "7.1.1.1. Connecting to Gremlin Server" it is suggested to connect to the remote server using conf/remote.yaml file where port is mentioned as 8183. However the default websocket port in various other configuration files (like conf/gremlin-server/gremlin-server.yaml file) is 8182. I was able to connect to the remote server by changing the port from 8183 to 8182.

Should the port in the remote.yaml file be changed from 8183 to 8182?

--
You received this message because you are subscribed to the Google Groups "JanusGraph users list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to janusgraph-use...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.