config skip-schema-check=true is not honored for HBase

jigar patel <jigar.9408266552@...> Insufficient permissions (user=<user>, scope=<namespace>:<table>, params=[table=<namespace>:<table>],action=CREATE)
at at

got above error while OLAP without create permission to <user> at line

it succeeded with CREATE permission given to user

looks like it is due to this call being made regardless of the boolean variable skipSchemaCheck value

is this a bug? 


Hi Jigar,

Can you provide the properties file you used for opening the graph, as well as the complete stacktrace for the exception listed above?

Best wishes,    Marc

jigar patel <jigar.9408266552@...>

Hi Marc

Here is the full stack trace,

possible fix is here:

Let me know if you think this is actually an issue, i can raise the PR against the master branch


Hi Jigar,

Yes, I think it is an issue. I did not fully dive into it, in particular I did not check whether any tests exist for the "disable schema check" configuration option. So, go ahead and create an issue for it.

Best wishes,   Marc