CQL scaling limit?


Hi all,

We've been trying to scale horizontally Janusgraph to keep up with the data throughput, but we're reaching some limit in scaling.
We've been trying different things to pinpoint the bottleneck but we're struggling to find it... Some help would be most welcome :)

Our current setup:

  • 6 ScyllaDB Instances
  • 6 Elasticsearch Instances
  • Our "indexers" running Janusgraph as a lib, they can be scaled up and down
    • They read data from our sources and write it to Janusgraph
    • Each Indexer runs on his own jvm
Our scaling test looks like this:

Each indexer counts the number of records it processes. We start with one indexer, and every 5 ~ 10 minutes we double the number of indexers and look how the overall performance increased.
From top down, left to right these panels represent:

  • Total Processed Records: The overall performance of the system
  • Average Processed Records: Average per Indexer, ideally this should be a flat curve
  • Number of Running Indexers: We scaled at 1, 2, 4, 8, 16, 32, 64
  • Processed Records Per Indexer
  • Cpu Usage: The cpu usage per Indexer
  • Heap: Heap usage per indexer. The red line is the max memory the Heap can take, we left a generous margin

As you can see past 4 Indexers, the performance per Indexer decreases until no additional throughput can be reached. At first we thought this might simply be due to resource limitations, but ScyllaDB and Elasticsearch are not really struggling. The ScyllaDB load, read and write latency looked good during this test:

Both ScyllaDB and Elasticsearch are running on NVMe hard disks, with 10GB+ of ram. ScyllaDB is also deployed with CPU pinning. If we try a Cassandra Stress test, we can really max out ScyllaDB.

Our janusgraph configuration looks like:


Each input record contains ~20 vertices and ~20 edges. The workflow of the indexer is:

  1. For each vertex, check if it exists in the graph using a composite index. Create it if it does not.
  2. Insert edges using the vertex id's returned by step 1

Each transaction inserts ~ 10 records. Each indexer runs 10 transactions in parallel.

We tried different things but without success:

  • Increasing/decreasing the transaction size
  • Increasing/decreasing storage.cql.batch-statement-size
  • Enabling/disabling batch loading
  • Increasing the ids.block-size to 10 000 000

The most successful test so far was to switch the cql write consistency level to ANY and the read consistency level to ONE:

This time the indexer scaled nicely up to 16 indexers, and the overall performance was still increased by scaling to 32 indexers. Once we reached 64 indexers though the performance dramatically dropped. There ScyllaDB had a little more load, but it still doesn't look like it's struggling:

We don't use LOCK consistency. We never update vertices or edges, so FORK consistency doesn't look useful in our case.

It really looks like something somewhere is a bottleneck when we start scaling.

I checked out the Janusgraph github repo locally and went through it to try to understand what set of operations Janusgraph does to insert vertices/edges and how this binds to transactions, but I'm struggling a little to find that information.

So, any idea/recommendations?


Boxuan Li


I didn't check your metrics but my first impression was this might be related to the internal thread pool. Can you try out the 0.6.0 pre-release version or master version? Remember to set `storage.cql.executor-service.enabled` to false. Before 0.6.0, an internal thread pool was used to process all CQL queries, which had a hard-coded 15 threads. https://github.com/JanusGraph/janusgraph/pull/2700 made the thread pool configurable, and https://github.com/JanusGraph/janusgraph/pull/2741 further made this thread pool optional.

EDIT: Just realized your problem was related to the horizontal scaling of JanusGraph instances. Then this internal thread pool thing is likely not related - but still worth trying.

Hope this helps.



Hi Boxuan,

I can definitively try from the 0.6.0 pre release or master version, that's a good idea,
I'll come back with the result,



Hi Marc,

Just to be sure: the indexers itself are not limited in the number of CPU they can grab? The 60 indexers run on the same machine? Or in independent cloud containers?

If the indexers are not CPU limited, it would be interesting to log where the time is spent: their own java code, waiting for transactions to complete, waiting for the id manager to return id-blocks?

Best wishes,   Marc


Hi Marc,

We're running on Kubernetes, and there's no cpu limitations on the indexer.
Thanks for pointing this out, I actually haven't checked the overall resources of the cluster... It's a good sanity check:

From left to right, top to bottom:

  • The total cpu usage per node on the cluster, there's about 20 of them and other non janusgraph applications are running, that's why it's not 0 when the tests are not running
  • The processed records per Indexer, there's two tests here in one panel:
    1. First group is the scaling test with the cql QUORUM consistency
    2. Second group is the scaling test with write consistency ANY and the read consistency ONE
  • The IO Waiting time per node in the cluster (unfortunately I don't have this metric per indexer)
  • ID block allocation warning logs events (the exact log message looks like "Temporary storage exception while acquiring id block - retrying in PT2.4S: {}")

The grey areas represents the moment when the overall performance stopped scaling linearly with the number of indexers.

We're not maxing out the cpus yet, so it looks like we can still push the cluster. I don't have the IO waiting time per indexer unfortunately, but the node-exporter metric on IO waiting time fits with the grey areas in the graphs.

As you mentioned the ID Block allocation, I checked the logs for warning messages, and they are actually id allocation warning messages, I looked for other warning messages but didn't find any.

I tried increasing the Id Block size to 10 000 000 but didn't see any improvement - that said, from my understanding of the ID allocation it is the perfect suspect. I'll rerun these tests on a completely fresh graph with ids.block-size=10000000 to double check.

If that does not work, I'll try upgrading to the master version and re run the test. Any tip on how to log which part is slowing the insertion? I was thinking maybe of using the org.janusgraph.util.stats.MetricManager to time the execution time of parts of the code of the org.janusgraph.graphdb.database.StandardJanusGraph.commit() method.

Thanks a lot,


Hi Marc,
If you know how to handle MetricManager, that sounds fine. I was thinking in more basic terms: adding some log statements to you indexer java code.

Regarding the id block allocation, some features seem to have been added, which are still largely undocumented, see:
Notice that the default value for ids.authority.conflict-avoidance-mode is NONE. Given the rigor you show in your attempts,  trying other values seems worth a try too!

Best wishes,    Marc


Just one more thing to rule out: did you set cpu.request and cpu.limit of the indexer containers to the same value? You want the pods to be really independent for this test.


Hi Marc,

I tried rerunning the scaling test on a fresh graph with ids.block-size=10000000 , unfortunately I haven't seen any performance gain.

I also tried ids.block-size=10000000 and ids.authority.conflict-avoidance-mode=GLOBAL_AUTO, but there also there was no performance gain.
I used GLOBAL_AUTO as it was the easiest to test, I ran the test twice to make sure the result was not just due to unlucky random tag assignment. I didn't do the math, but I guess I would have to be very unlucky to get twice a very bad random tag allocation!


I tried something else which turned out to be very successful:

instead of inserting all the properties in the graph, I tried only inserting the ones necessary to feed the composite indexes and vertex-centric indexes. The indexes are used to execute efficiently the "get element or create it" logic. This test scaled quite nicely up to 64 indexers (instead of 4 before)!

Out of all the tests I tried so far, the two most successful ones were:

  1. decreasing the cql consistency level (from Quorum to ANY/ONE)
  2. decreasing the number of properties

What's interesting with these two cases, is that they didn't significantly increased the performance of a single indexer, they really increased the horizontal scalability we could achieve.

My best guess for why it is the case: they reduced the amount of work the ScyllaDB coordinators had to do by:

  1. decreasing the amount of coordination necessary to get a majority answer (Quorum)
  2. decreasing the size in bytes of the cql unlogged batches, some of our properties can be quite big ( > 1KB )

I would happily continue digging into this, unfortunately we have other priorities that turned up. We're putting the testing on the side for the moment.

I thought I would post my complete findings/guess anyway in case they are useful to someone.


Thank you so much for your help!


Nice work!