Topics

JanusGraph 0.5.3 using Gremlin Server 3.4.10


James Stroud
 

Hi, My team is using JanusGraph version 0.5.3.  I want my team to use Gremlin Server 3.4.10 as opposed to 3.4.6 that comes bundled with JanusGraph 0.5.3
I suppose it would work based upon this (and reading the change logs)

I searched the forums and could not see if anyone was using this combination.

I just want to check if any JanusGraph users of version 0.5.3 are using Apache Tinkertop Gremlin Server 3.4.10


If anyone is can you just let me know as that will help.  Thanks
James Stroud


hadoopmarc@...
 

Hi James,

Best approach is to do a custom build of janusgraph with the version of TinkerPop changed (you can use -D skipTests because TInkerPop API have not changed). With the maven dependency plugin it is easy to find newly introduced library version conflicts, which may have to be solved manually by exluding unwanted versions. It will require some study of the entire project becuase JanusGraph has an extensive hierarchy of modules, each with its own pom.xml. It is also a kind of magic, but with only a few version conflicts the number of permutations is small ...

Best wishes,    Marc


hadoopmarc@...
 

Also check:

https://github.com/JanusGraph/janusgraph/commit/7fbf6567f259b2514e64e7a70e668e7975b38a72

This suggests that no new library conflicts occur.

Marc